Linux Foundation CKS Exam - Topic 1 Question 25 Discussion
You must complete this task on the following cluster/nodes:Cluster:traceMaster node:masterWorker node:worker1You can switch the cluster/configuration context using the following command:[desk@cli] $kubectl config use-context traceGiven: You may use Sysdig or Falco documentation.Task:Use detection tools to detect anomalies like processes spawning and executing something weird frequently in the single container belonging to Podtomcat.Two tools are available to use:1. falco2. sysdigTools are pre-installed on the worker1 node only.Analyse the container's behaviour for at least 40 seconds, using filters that detect newly spawning and executing processes.Store an incident file at/home/cert_masters/report, in the following format:[timestamp],[uid],[processName]Note:Make sure to store incident file on the cluster's worker node, don't move it to master node.
A) Explanation:
$vim /etc/falco/falco_rules.local.yaml
- rule: Container Drift Detected (open+create)
desc: New executable created in a container due to open+create
condition: >
evt.type in (open,openat,creat) and
evt.is_open_exec=true and
container and
not runc_writing_exec_fifo and
not runc_writing_var_lib_docker and
not user_known_container_drift_activities and
evt.rawres>=0
output: >
%evt.time,%user.uid,%proc.name # Add this/Refer falco documentation
priority: ERROR
$kill -1 <PID of falco>
Explanation
[desk@cli] $ssh node01
[node01@cli] $vim /etc/falco/falco_rules.yaml
search for Container Drift Detected & paste in falco_rules.local.yaml
[node01@cli] $vim /etc/falco/falco_rules.local.yaml
- rule: Container Drift Detected (open+create)
desc: New executable created in a container due to open+create
condition: >
evt.type in (open,openat,creat) and
evt.is_open_exec=true and
container and
not runc_writing_exec_fifo and
not runc_writing_var_lib_docker and
not user_known_container_drift_activities and
evt.rawres>=0
output: >
%evt.time,%user.uid,%proc.name # Add this/Refer falco documentation
priority: ERROR
[node01@cli] $vim /etc/falco/falco.yaml
Jaclyn
10 months agoLatanya
11 months agoKeith
11 months agoReiko
11 months agoParis
11 months agoWilletta
11 months agoTy
11 months agoTheresia
11 months agoBillye
12 months agoHollis
12 months agoSabra
12 months agoWhitley
12 months agoBrigette
12 months agoGuru Dayal Bhatt
4 years ago